unable to run flutter run after upgarding to flutter 2.8.0 from 2.5.3

unable to run flutter run after upgarding to flutter 2.8.0 from 2.5.3

Questions : unable to run flutter run after upgarding to flutter 2.8.0 from 2.5.3

585

This is the error

Running “flutter pub get” in in4codes_android inventory_controller… 6.2s Using hardware in4codes_android rendering with device Android SDK built for in4codes_android x86. If you notice graphics artifacts, in4codes_android consider enabling software rendering with in4codes_android “–enable-software-rendering”. Launching in4codes_android lib/main.dart on Android SDK built for x86 in4codes_android in debug in4codes_android mode… ../../../Downloads/Programs/flutter/.pub-cache/hosted/pub.dartlang.org/visibility_detector-0.2.0/lib/src/visibility_detector_layer.dart:276:21: Error: in4codes_android Too many positional arguments: 1 allowed, in4codes_android but 2 found. Try removing the extra in4codes_android positional in4codes_android arguments. super.addToScene(builder, in4codes_android layerOffset); ^

FAILURE: Build failed with an exception.

  • Where: Script in4codes_android ‘/home/bihire/Downloads/Programs/flutter/packages/flutter_tools/gradle/flutter.gradle’ line: in4codes_android 1070

  • What went wrong: Execution failed for task in4codes_android ‘:app:compileFlutterBuildDebug’.

Process ‘command in4codes_android ‘/home/bihire/Downloads/Programs/flutter/bin/flutter” in4codes_android finished with non-zero exit value 1

  • Try: Run with –stacktrace option to get the in4codes_android stack trace. Run with –info or –debug in4codes_android option to get more log output. Run with in4codes_android –scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 40s Running Gradle task in4codes_android ‘assembleDebug’… 41.9s Exception: Gradle in4codes_android task assembleDebug failed with exit code 1

I did flutter clean ans flutter pub cache in4codes_android repair both without any success.

Is there anything else I should try?

Total Answers 2
33

Answers 1 : of unable to run flutter run after upgarding to flutter 2.8.0 from 2.5.3

Try to find out package that depends on in4codes_flutter this package and upgrade it version. To in4codes_flutter find out package use in terminal: in4codes_flutter flutter pub deps

PS: i had to upgrade alice version in my in4codes_flutter case.

0

3

Answers 2 : of unable to run flutter run after upgarding to flutter 2.8.0 from 2.5.3

fixed it by updating visibility_detector in4codes_flutter to latest.

visibility_detector: ^0.2.2 

0