Installing Laravel v5.4 on Ubuntu using Composer: Troubleshooting Errors

Feedback


Question:

Encountered an error while trying to install Laravel version 5.4.

a get error this :

The file “http://packagist.org/p/provider-2016%24e217873bdc8408956b33b1eb317ad1182d3a82fde9a746cc5e7def6135696f96.json” failed to download due to HTTP/1.1 500
Internal Server Error
. As http://packagist.org could not be fully loaded, the package information was fetched from the local cache which might be outdated
Installing laravel/laravel
(v5.5.0). The installation process of laravel/laravel (v5.5.0) was carried out by loading from cache and the project was successfully created in blog. The command @php -r “file_exists(‘.env’) || copy(‘.env.example’, ‘.env’);” was executed. The composer repositories were loaded with the package information, and the dependencies were updated, including require-dev.

Encountered an error while attempting to
decode response: zlib_decode(): data error
. In order to resolve the issue, retrying with degraded mode is recommended. Additional details can be found in

https://getcomposer.org/doc/articles/troubleshooting.

and md#degraded-mode. The package requirements could not be satisfied for installation.

Problem 1
- phpunit/phpunit 6.4.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.4.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.3.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.3.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.2.4 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.2.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.2.2 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.2.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.2.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.1.4 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.1.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.1.2 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.1.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.1.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.9 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.8 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.7 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.6 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.5 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.4 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.2 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.13 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.12 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.11 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.10 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.1 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- phpunit/phpunit 6.0.0 requires ext-dom * -> the requested PHP extension dom is missing from your system.
- Installation request for phpunit/phpunit ~6.0 -> satisfiable by phpunit/phpunit[6.0.0, 6.0.1, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.1.4, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.2.4, 6.3.0, 6.3.1, 6.4.0, 6.4.1].

I require assistance in solving this problem as my attempts have yielded no results.


Solution:

In case you have PHP 7 or a newer version, you have the option to install

ext-dom

simply by executing the given command.

sudo apt-get install php7.0-xml // for PHP 7
sudo apt-get install php7.1-xml // for PHP 7

Frequently Asked Questions